Penneo incident - Users will experience a blank/white page when signing a rejected or expired document
Incident Report for Scalepoint Technologies
Resolved
Penneo reports that this incident has been solved.
Posted Dec 05, 2022 - 11:33 CET
Identified
Penneo are aware of the white/blank page some users will experience, when trying to sign documents. If the document is rejected/expired/signed, it will show you the white/blank page.
Penneo working on a releasing a fix for this as soon as possible.
Posted Dec 05, 2022 - 08:29 CET
This incident affected: HUB - Health (Communication).