Here you can see the current status of all Scalepoint systems and planned maintenance.
Investigating
Fix has been published.
Incident resolved.
Identified
Some of our users are currently experiencing issues in ClaimShop Settlement and the Shop.
Some claim handlers and users are unable to complete work and gain access to their settlement.
The issue is being investigated with the highest priority, and we will provide an update as soon as we have additional information to provide and/or the issue has been resolved.
Investigating
Some of our users are currently experiencing issues in ClaimShop Settlement and the Shop.
The issue is being investigated with the highest priority, and we will provide an update as soon as we have additional information to provide and/or the issue has been resolved.