Here you can see the current status of all Scalepoint systems and planned maintenance.
Resolved
Incident has been resolved.
Monitoring
A fix has been implemented. We are monitoring the results.
Identified
We have identified the cause and a working towards a solution.
Investigating
Some claim handlers and users are unable to load Catalogue in Settlement tool.
The issue is being investigated with the highest priority, and we will provide an update as soon as we have additional information to provide and/or the issue has been resolved.