We are continuing to observe errors affecting the Widget tool in Selfservice, and our investigation is ongoing. We apologize for the inconvenience this may be causing our users.
Posted Apr 20, 2026 - 11:25 CEST
Update
A fix has been introduced to Selfservice. We are monitoring the results.
Posted Apr 20, 2026 - 10:53 CEST
Update
We have observed erros in the Selfservice module, claimaints use to regristrer items. Work is ongoing to resolve the issue.
Posted Apr 20, 2026 - 10:43 CEST
Monitoring
Fix has been implemented and we are monitoring the results.
Posted Apr 20, 2026 - 10:22 CEST
Identified
Some of our users are currently experiencing issues with Repair & Valuation.
The issue has been identified and we are working towards a solution with the highest priority. We will provide an update as soon as we have additional information to provide and/or the issue has been resolved.
Posted Apr 20, 2026 - 10:16 CEST
This incident affects: ClaimShop (Repair & Valuation).