EasyClaims is inaccessible
Incident Report for Scalepoint Technologies
Resolved
We are happy to confirm that this incident has been resolved.

Users of the EasyClaims system can access the system again and continue to work.
Posted May 10, 2022 - 12:48 CEST
Monitoring
It seems EasyClaims is once again accessible. We will continue to monitor the situation before resolving this incident.
Posted May 10, 2022 - 12:21 CEST
Investigating
We are currently experiencing issues accessing EasyClaims.
Posted May 10, 2022 - 11:58 CEST
This incident affected: HUB - Property (All (Entire system affected), AI Cost Control, Mobile App) and HUB - Health (All (Entire system affected), AI Cost Control).