Some of our users are experiencing issues in HUB Property.

Incident Report for Scalepoint

Resolved

A fix has been implemeted so users can request service partners again.
Posted Jul 31, 2025 - 12:25 CEST

Update

Issue seem to related external map service.

We are still investigating the issue.
Posted Jul 31, 2025 - 11:07 CEST

Investigating

Some of our users are experiencing issues in HUB Property when ordering service partners.

The issue is being investigated with the highest priority, and we will provide an update as soon as we have additional information to provide and/or the issue has been resolved.
Posted Jul 31, 2025 - 10:46 CEST
This incident affected: ClaimsCORE and HUB (HUB Property).