Scheduled Maintenance - CORE & HUB - Server Maintenance

Scheduled for Jul 25, 21:00 CEST  -  Jul 26, 05:00 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 01, 2025 - 15:36 CEST

Scheduled

We will be undergoing scheduled maintenance during this time.
Posted Jun 30, 2025 - 11:16 CEST
This scheduled maintenance affects: ClaimsCORE and HUB (All (Entire system affected), Automation Engine, Communication, HUB Motor, HUB Health, HUB Property, Mobile App (Scalepoint HUB Property)).