Degraded performance in Settlement tool

Incident Report for Scalepoint

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 13:57 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 31, 2025 - 13:19 CEST

Identified

We have identified an issue that may have users experience issues with degraded performance in Settlement tool. 

What does this mean?
Claimhandlers may experience degraded performance using Settlement tool. The issue is being investigated with the highest priority, and we will provide an update as soon as we have additional information to provide or the issue has been resolved.
Posted Mar 31, 2025 - 11:45 CEST
This incident affected: ClaimShop (All (Entire system affected), Catalogue, Settlement).