Degraded performance - HUB Health

Incident Report for Scalepoint

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 12:40 CET

Monitoring

We continue to monitor the situation. Once word of MitID is working again, we will report back.
Posted Feb 27, 2026 - 11:38 CET

Investigating

Many users are experiencing issues with MitID.

The issue is being reported by external provider as a general issue with MitID. We will provide an update as soon as we have additional information to provide and/or the issue has been resolved.
Posted Feb 27, 2026 - 11:11 CET
This incident affected: ClaimsCORE and HUB (HUB Health).